

    
      
          
            
  
NRSDK User Guide


Note

Here is the NRSDK1.7.0 version of the use of the document, welcome to use.
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Video Capture





Getting Started

If you dont know how to use NRSDK. You can see this Quickstart for Android to have a quick start with NRSDK.






Import the NRSDK for First Person View
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Hand Tracking

This guide will introduce what NRSDK can & cannot do while tracking
hands. The tutorial will demonstrate how to add the hand tracking
feature to your app and use your hands as an interaction model.

Notice


	MR Apps using the Hand Tracking feature in NRSDK 1.7.0 can only operate until 12/31/2022.


	This feature is under Beta phase, more devices/models will be supported in the next release of NRSDK.


	
	This feature is fully tested on the following devices:

	
	Nreal DevKit


	Nreal Enterprise Kit


	OnePlus：9R / 7T


	LG：V60 / V50S ThinQ 5G / V50 ThinQ 5G / G9（Velvet 5G） / Wing


	SONY：Xperia 5 II / Xperia 1


	SAMSUNG：Galaxy Note20 5G / Galaxy S10+ / Galaxy S20+ 5G / Galaxy Z Fold 2 5G /


	Galaxy Note 20UItra / Galaxy Note10+ 5G / GalaxyA90 5G


	ZTE Axon 10 pro


	Black Shark 2 ProNreal DevKit










	Snapdragon888 / Exynos based models cannot be operated, will be supported in the next release of NRSDK


	The operation of other devices is currently unknown





Introduction

NRSDK’s Hand Tracking capability tracks the position of key points of
your hands and recognizes hand poses in real-time. Hand poses are shown
in the first-person view and used to interact with virtual objects
immersively in-world.



Capabilities


	The NRSDK can track hands through the world coordinate frame and
annotated the position and orientation of twenty-three key points；


	The NRSDK currently supports six hand poses from either hand;


	While tracking hand poses, the NRSDK also returns to a state of
whether there are hands being tracked;


	Left/Right hand detection is available in NRSDK;


	When using hands as input, the hand’s pose drives a laser
cursor-pointer that behaves like the standard controller cursor.






Hand Poses


General Gesture


[image: ../../../_images/ht1-1.png]



Select Gesture


[image: ../../../_images/ht1-2.png]


	As long as the index finger and thumb pinch together (regardless of
the pose of other fingers), it is considered a pinch pose.


	Gestures above will all be recognized as pinch/select.






System Gesture


[image: ../../../_images/ht1-3.png]


	Keep this gesture for 1.2s to evoke the home menu.


	Both left and right hands will be recognized.







Hand Pointer

Similar to a controller, NRSDK provides a pointer for each hand to
interact with targets. The pointer pose and whether the pointer pose is
being tracked can be obtained from HandState of each hand.

The pointer pose must meet the following conditions to be correctly
tracked:


	The hand is recognized


	The palm direction is pointing forward




A basic hand pointer style is included in NRHand_R and NRHand_L
prefabs located in Assets>NRSDK>Prefabs>Hands. You can also customize the style of Hand
Pointer based on the pointer pose and related data, combined with some
data in NRPointerRaycaster.



Joint

The NRSDK hand tracking system identifies the position of 23 key points
on the hand for every recognized hand pose(position and orientation).


Joint Label



Index







	Index

	API Name





	0

	Wrist



	1

	Palm



	2

	ThumbMetacarpal



	3

	ThumbProximal



	4

	ThumbDistal



	5

	ThumbTip



	6

	IndexProximal



	7

	IndexMiddle



	8

	IndexDistal



	9

	IndexTip



	10

	MiddleProximal



	11

	MiddleMiddle



	12

	MiddleDistal



	13

	MiddleTip



	14

	RingProximal



	15

	RingMiddle



	16

	RingDistal



	17

	RingTip



	18

	PinkyMetacarpal



	19

	PinkyProximal



	20

	PinkyMiddle



	21

	PinkyDistal



	22

	PinkyTip








Joint Orientation


[image: ../../../_images/ht1-4.png]




Common Usage Of Hand Tracking

Sample Use Case:

	 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14

	  //returns true if input source switch to hand tracking success
  bool switchToHandTracking = NRInput.SetInputSource(InputSourceEnum.Hands);

  //returns true if input source switch to controller success bool
  switchToController = NRInput.SetInputSource(InputSourceEnum.Controller);

  //returns true if hand tracking is running bool isRunning =
  NRInput.Hands.IsRunning;

  //returns the NRHand of right-handness NRHand hand =
  NRInput.Hands.GetHand(HandEnum.RightHand);

  //returns true if user is now performing system gesture bool
  isPerformingSystemGesture = NRInput.Hands.IsPerformingSystemGesture();







Details Of HandState:

	 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

	  //returns the HandState of  right-handness
  HandState handState = NRInput.Hands.GetHandState(HandEnum.RightHand);

  //returns the handness of this hand
  HandEnum handEnum = handState.handEnum;

  //returns true if this hand is tracked
  bool isTracked = handState.isTracked;

  //returns the start pose of hand ray pointer
  Pose pointerPose = handState.pointerPose;

  //returns ture if hand ray pointer pose is valid
  bool pointerValid = handState.pointerPoseValid;

  //returns true if this hand is performing pinching
  bool isPinching = handState.isPinching;

  //returns the current pinch strength value of hand. The range is from 0 to 1
  float pinchStrength = handState.pinchStrength;

  //returns the current gesture of hand
  HandGesture handGesture = handState.currentGesture;

  //returns the pose which contains position and orientation of thumb tip joint
  Pose thumbTipPose = handState.GetJointPose(HandJointID.ThumbTip);









Tutorial


Enabling Hand Tracking


	Create a new project in Unity with NRSDK. Refer to Quickstart for
Android
Unity [https://developer.nreal.ai/develop/unity/android-quickstart]
for more setting up instructions.


	Delete the Main Camera from the scene hierarchy.


	Find NRCameraRig and NRInput prefab from
Assets>NRSDK>Prefabs>NRCameraRig. Drag them to the scene
hierarchy. [image: image0]


	Select the NRInput GameObject in the Hierarchy window to open the
Inspector window, and choose Hands as Input Source Type.
[image: image1]


	Find NRHand_R and NRHand_L from
Assets>NRSDK>Prefabs>Hands. Add them as child GameObjects of
Left and Right anchor in NRInput correspondingly.
[image: image2]


	Now you are ready for hand tracking, refer to Building a Project
with User
Input [https://developer.nreal.ai/develop/unity/controller] for
adding more interactions with objects.




Samples are included in the plugin. Please refer to
Assets>NRSDK>Demos>HandTracking for details.




Requirements & Limits


	Hand tracking SDK uses on-board camera(s) to detect hands, so make
sure hands are visible from the camera.


	We are improving the accuracy of the model, please pay attention to the following
situations if your hand is not detected:




Backgrounds


	Avoid complicated backgrounds, solid backgrounds are preferred;


	Avoid backlight or low light, or unbalanced lighting conditions in
camera frame；




Gesture


	Avoid stacked or interlaced fingers for either hand；


	Avoid the hands of different people;


	Avoid fast-moving;


	There are chances that the orientations of the joints are recognized
converted. If so, please move your hands out of the visible fields
and move them back again.
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Notification popup window


Ordinary prompt window

Ordinary prompt window provides information about the status of the devices, such as slam tracking state, glasses temprature level, device battery state.

[image: image0]

Enable Notification


	Find the NRSessionConfig in your project

[image: image1]



	Check the “Enable Notifiction” box

[image: image2]





Notification types


	Currently provided notifiction windows:


	Slam tracking lost


	Glasses Temperature Warm


	Glasses Temperature Hot


	Phone Battery 30% Notification


	Phone Battery 15% Notification






	Please refer to NRNotificationListener prefab under NRSDK>Resources and its NRNotificationListener.cs script to customize your notification message.

[image: image3]







Error prompt window

Error prompt window provides information for sever error. It usually pops up when the devices has been unable to run properly.

[image: image4]

Customize error tips


	Find the NRErrorTips prefab under NRSDK>Resources, copy it to your project.


	Modify and save it as a new prefab, and drag it to your SessionConfig.

[image: image5]

[image: image6]



	Modify prompt text

	1
2
3
4
5
6

	// Static constants need to be replaced in awake
void Awake()
{
    NativeConstants.GlassesDisconnectErrorTip = "Please connect your Nreal Light Glasses.";
    NativeConstants.UnknowErrorTip = "Unkown error! \nPlease contact Nreal's customer service.";
}
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NRSDK Coordinate System for Plugins

This document describes the definition of coordinate systems of the Nreal glass components. Please note that this document is not for application developers (upward rendering purposes), but for third-party software solution providers (downward plugins).


Glass Components and Coordinate Systems


	The Nreal glass consists of the following key components



	2 x Grayscale Cameras


	2 x Display Cameras


	Head / IMU


	RGB Camera









	The placement of the above components and their corresponding coordinate systems, as defined in NRSDK, are as follows [image: image0]





Interface for Head(IMU) Pose


	Interface function: This function returns the 6dof pose, of the target_device in the source_device.




	1
2

	   // head pose(IMU,"NRCameraRig" transform in Unity)
   Pose headpose = NRFrame.HeadPose;








	Enum for component (device) names




	 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

	   public enum NativeDevice
   {
       /// <summary>
       /// Left display.
       /// </summary>
       LEFT_DISPLAY = 0,

       /// <summary>
       /// Right display.
       /// </summary>
       RIGHT_DISPLAY = 1,

       /// <summary>
       /// RGB camera.
       /// </summary>
       RGB_CAMERA = 2,

       /// <summary>
       ///  The left grayscale camera.
       ///  Only supported in the version of preview.
       /// </summary>
       LEFT_GRAYSCALE_CAMERA = 3,

       /// <summary>
       ///  The right grayscale camera.
       ///  Only supported in the version of preview.
       /// </summary>
       RIGHT_GRAYSCALE_CAMERA = 4,
   }







Example 1: Getting the Pose Between the Head/IMU and the Left Display, Right Display, RGB Camera

	 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11

	   // camera external parameters
   var eyePoseFromHead = NRFrame.EyePoseFromHead;

   // left display local pose from "NRCameraRig"
   Pose left_display = eyePoseFromHead.LEyePose;

   // right display local pose from "NRCameraRig"
   Pose right_display = eyePoseFromHead.REyePose;

   // rgb camera local pose from "NRCameraRig"
   Pose rgb_camera = eyePoseFromHead.RGBEyePose;







Example 2: Getting the Extrinsics Between the Head/IMU and the Left Grayscale Camera

	1
2

	   // This interface only supported in the version of Preview, not release version
   Pose leyeGrayEyePose = NRFrameExtension.GrayEyePoseFromHead.LEyePose;







[image: image2]




Head/IMU Pose in Global Coordinate System


	The global coordinate frame of the tracking system is as follows




[image: image3]



Camera Coordinate System (OpenGL)


	The definition of the camera’s coordinate frame in the NRSDK follows the OpenGL convention, i.e. X-right, Y-upward, Z-backward. For developing and using computer vision algorithms, you may need to convert the camera coordinates to the OpenCV convention, which simply requires negating the Y and Z coordinates.




[image: image4]



Image Pixel Coordinate System and Camera Intrinsics (OpenCV)


	The definition of the image pixel coordinates and the camera intrinsics in the NRSDK follows the OpenCV convention. The image data is stored row wise in memory.




[image: image5]


	Interface for getting the camera’s intrinsic parameters




	1

	   NRFrame.GetDeviceIntrinsicMatrix(NativeDevice device);









Wireframes

[image: image6]
[image: image7]
[image: image8]
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NRSDK XRPlugin Introduction

This document describes how to develop MR applications that run on Nreal MR Glasses with NRSDK Unity XR Platform SDK in Unity, and how to simplify the developing process in Unity with XRSDK. The functions SDK provides include sensor fusion, binocular stereo rendering, correction of optical distortion, etc. It is recommended to set up your project as stated in this document, to meet the minimum technical requirements defined in the NRSDK guidelines.

Before using this SDK, we recommend that you read the Unity XR documentation [https://docs.unity3d.com/Manual/XR.html] as you need to be familiar with Unity XR. This SDK provides basic XR features that follow the XR specification established by Unity. If your project aims to use Unity’s API or package, you can add this plugin to your project.

SDK package is released in supported format of the Package Manager, and the folder structure is shown as below after SDK is imported:

[image: ../../../_images/xr1-1.png]
*Please note this is a preview version.


SDK Plugin content

The primary scripts for NRSDK and editor related scripts are included in Runtime>Scripts.

The Android runtime library used in NRSDK is included in Runtime>Android.

[image: ../../../_images/xr1-2.png]



Enable NRSDK XRPlugin

To use Unity XR related features，you need to enable XRPlugin in Unity.

Unity 2019.3 and newer versions use a new, unified plug-in framework that enables direct integrations for multiple platforms, including NRSDK.

To enable NRSDK XRPlugin:


	In the menu, go to Window->Package Manager.




[image: ../../../_images/xr1-3.png]

	Click + and choose Add package from git URL, fill in https://github.com/nreal-ai/NRSDK-XR-Plugin.git.




[image: ../../../_images/xr1-4.png]
[image: ../../../_images/xr1-5.png]

	After successfully loaded, go to Edit>Project Settings>XR Plug-in Management, click the Android tab, and select NRSDK to install the NRSDK XR plugin, which enables the XR support.




[image: ../../../_images/xr1-6.png]

	After successfully imported, the NRSDK set up window will pop up, click Fix or Accept All, XR related features in NRSDK will be enabled automatically. (You can also find the window in NRSDK>Project Tips)




[image: ../../../_images/xr1-7.png]
At the same time, USING_XR_SDK will also be automatically added to Scripting Define Symbols in Player Setting.

[image: ../../../_images/xr1-8.png]


Disable NRSDK XRPlugin

To disable NRSDK XRPlugin，please follow:


	In the menu, go to Window>Package Manager, choose NRSDK XR Plugin and click Remove at the bottom.




[image: ../../../_images/xr1-9.png]

	After removing, the NRSDK set up window will pop up, click Fix or Accept All, XR related features in NRSDK will be disabled automatically. (You can also find the window in NRSDK>Project Tips)




[image: ../../../_images/xr1-10.png]
At the same time, USING_XR_SDK will also be automatically deleted from Scripting Define Symbols in Player Setting.



API Interface Function List

Please find APIs provided by UnityXR plugins at Unity User Manual [https://docs.unity3d.com/Manual/VRReference.html]

Currently supported modules in NRSDK XRPlugin:


	XRDisplaySubsystem [https://docs.unity3d.com/Manual/xrsdk-display.html]


	XRNodeState [https://docs.unity3d.com/ScriptReference/XR.XRNodeState.html]


	XRStats [https://docs.unity3d.com/ScriptReference/XR.XRStats.html]






Advanced Features


Single Pass

SinglePass is based on native Unity Single Pass [https://docs.unity3d.com/Manual/SinglePassStereoRendering.html] feature. It uses one camera to fulfill stereo rendering, reducing half of Draw Call and Occlusion Culling. Using this feature can increase frame rate dramatically in complex scenes. But SinglePass doesn’t support post processing.

MutiView shown below is the original SinglePass mode:

[image: ../../../_images/xr1-11.png]



Performance optimization Guide


Parameters Suggestions


	The application frame rate should not be less than 45 frames.


	Avoid more than 100,000 triangular patches being rendered in the camera view.


	Avoid more than 100,000 model vertices being rendered in the camera view.


	Avoid more than 50 common unity lights such as electric light sources.


	Avoid more than 50 ordinary unity particle systems.


	Avoid more than 1 pixel light.


	Avoid more than 1.2 render scale.


	Avoid more than 2 shader passes.


	Watch for greater than 2k by 2k texture resolution after LOD bias.


	Avoid slow physics settings such as Sleep Threshold values of less than 0.005, Default Contact Offset values of less than 0.01, or Solver Iteration Count settings greater than 6.






Best Practices


	Try to use the more efficient Unity shader


	Use trilinear or anisotropic filtering on textures. See Textures in the Unity Manual for more information.


	Use mesh-based occlusion culling (see Occlusion Culling in the Unity Manual).


	Always use the Forward Rendering path (see Forward Rendering Path Details in the Unity Manual).


	Verify that non-static objects with colliders are not missing rigidbodies in themselves or in the parent chain.


	Avoid inefficient effects such as SSAO, motion blur, global fog, parallax mapping.


	Avoid excessive use of multipass shaders (e.g., legacy specular).


	Avoid large textures or using a lot of prefabs in startup scenes (for bootstrap optimization). When using large textures, compress them when possible.


	Avoid realtime global illumination.


	Disable shadows when approaching the geometry or draw call limits.


	Be cautious using Unity WWW and avoid large file downloads. It may be acceptable for very small files.


	For Android apps with voice chat, you should use the Microphone APIs to avoid issues with Parties. For more information about Parties, go to the Parties and Party Chat topic.


	Enable SinglePass renderring.


	Disable Plane Detection or ImageTracking in Settings if not in use.
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NRSDK Scripting API


Session Events

public class SessionEventsListener : MonoBehaviour
 {
     void Awake()
     {
         // Tracking mode changed event.
         NRSessionManager.OnChangeTrackingMode += OnChangeTrackingMode;
         // Glasses disconnected event.
         NRSessionManager.OnGlassesDisconnect += OnGlassesDisconnect;
         // Glasses state changed event,PutOn,PutOff.
         NRSessionManager.OnGlassesStateChanged += OnGlassesStateChanged;
         // Tracking state lost event.
         NRSessionManager.OnHMDLostTracking += OnHMDLostTracking;
         // Tracking state ready event.
         NRSessionManager.OnHMDPoseReady += OnHMDPoseReady;
         // Session kernal error event, such as NRRGBCameraDeviceNotFindError, NRPermissionDenyError, NRUnSupportedHandtrackingCalculationError.
         NRSessionManager.OnKernalError += OnKernalError;
     }

     /// <summary>
     /// Session kernal error event.
     /// </summary>
     /// <param name="exception">NRRGBCameraDeviceNotFindError, NRPermissionDenyError, NRUnSupportedHandtrackingCalculationError</param>
     private void OnKernalError(NRKernalError exception)
     {
         NRDebugger.Info("[SessionEventsListener] OnKernalError.");
     }

     private void OnHMDPoseReady()
     {
         NRDebugger.Info("[SessionEventsListener] OnHMDPoseReady.");
     }

     private void OnHMDLostTracking()
     {
         NRDebugger.Info("[SessionEventsListener] OnHMDLostTracking.");
     }

     private void OnGlassesStateChanged(NRDevice.GlassesEventType eventtype)
     {
         NRDebugger.Info("[SessionEventsListener] OnGlassesStateChanged:" + eventtype.ToString());
     }

     private void OnGlassesDisconnect(GlassesDisconnectReason reason)
     {
         NRDebugger.Info("[SessionEventsListener] OnGlassesDisconnect:" + reason.ToString());
     }

     private void OnChangeTrackingMode(NRHMDPoseTracker.TrackingType origin, NRHMDPoseTracker.TrackingType target)
     {
         NRDebugger.Info("[SessionEventsListener] OnChangeTrackingMode, from:{0} to:{1}", origin, target);
     }
 }







Supported Features

As different devices support different features, You can check the feature before using it.

bool support = NRDevice.Subsystem.IsFeatureSupported(NRSupportedFeature.NR_FEATURE_TRACKING_6DOF);





public enum NRSupportedFeature
{
    NR_FEATURE_TRACKING_6DOF = 1,
    NR_FEATURE_TRACKING_3DOF,
    NR_FEATURE_TRACKING_FINDING_HORIZONTAL_PLANE,
    NR_FEATURE_TRACKING_FINDING_VERTICAL_PLANE,
    NR_FEATURE_TRACKING_FINDING_MARKER,
    NR_FEATURE_CONTROLLER_3DOF,
    NR_FEATURE_CONTROLLER_6DOF,
    NR_FEATURE_WEARING_STATUS_OF_GLASSES,
    NR_FEATURE_HANDTRACKING,
    NR_FEATURE_RGB_CAMERA,
}







Glasses SN (Experimental feature)

string sn = NRDevice.Instance.NativeGlassesController?.GetGlassesSN();







Device Parameters

// display project matrix
var matrix_data = NRFrame.GetEyeProjectMatrix(out result, 0.03f, 100f);
// left display
Matrix4x4 left_display_matrix = matrix_data.LEyeMatrix
// right display
Matrix4x4 left_display_matrix = matrix_data.LEyeMatrix


// camera external parameters
var eyePoseFromHead = NRFrame.EyePoseFromHead;
// left display local pose from "NRCameraRig"
Pose left_display = eyePoseFromHead.LEyePose;
// right display local pose from "NRCameraRig"
Pose right_display = eyePoseFromHead.REyePose;
// rgb camera local pose from "NRCameraRig"
Pose rgb_camera = eyePoseFromHead.RGBEyePose;


// rgb camera intrinsic matrix
NativeMat3f rgb_in_mat = NRFrame.GetRGBCameraIntrinsicMatrix();

// rgb camera distortion
NRDistortionParams rgb_in_mat = NRFrame.GetRGBCameraDistortion();






Camera Properties




Gray Camera Data (Preview feature)

var grayCameraDataProvider = new GrayCameraDataProvider(NativeGrayEye.LEFT);
grayCameraDataProvider.Play();





After initialize grayCameraDataProvider, the developer could access gray camera data by grayCameraDataProvider.RawData or grayCameraDataProvider.Texture.

The GrayCameraDataProvider is following.

using NRKernal;
using NRKernal.Preview;
using System;
using UnityEngine;

public class GrayCameraDataProvider : CameraModelView
{
    private NativeGrayEye m_Eye;
    public NativeGrayEye Eye
    {
        get { return m_Eye; }
    }

    private Texture2D m_Texture;
    public Texture2D Texture
    {
        get { return m_Texture; }
    }

    private byte[] m_RawData;
    public byte[] RawData
    {
        get { return m_RawData; }
    }

    private ulong m_TimeStamp;
    public ulong TimeStamp
    {
        get { return m_TimeStamp; }
    }

    public GrayCameraDataProvider(NativeGrayEye eye)
    {
        m_Eye = eye;

        m_NativeCameraProxy = CameraProxyFactoryExtension.CreateGrayCameraProxy(m_Eye);
        m_NativeCameraProxy.Regist(this);

        InitTexture();
    }

    private void InitTexture()
    {
        if (m_Texture == null)
        {
            m_Texture = new Texture2D(Width, Height, TextureFormat.R8, false);
        }
    }

    protected override void OnRawDataUpdate(FrameRawData frame)
    {
        base.OnRawDataUpdate(frame);

        // Copy the raw data of the specified eye
        int size = frame.data.Length / 2;
        int offset = m_Eye == NativeGrayEye.LEFT ? 0 : size;
        if (m_RawData == null)
        {
            m_RawData = new byte[size];
        }
        Array.Copy(frame.data, offset, m_RawData, 0, size);

        // Fill in texture with raw data
        m_Texture.LoadRawTextureData(m_RawData);
        m_Texture.Apply();

        m_TimeStamp = frame.timeStamp;
    }
}







Intrinsic parameters

Intrinsic parameters are specific to a camera. They include information like focal length (fx,fy) and optical centers (cx,cy).

using NRKernal.Preview;

// Get fc, cc of left eye
matrix = NRFrameExtension.GetGrayCameraIntrinsicMatrix(NativeGrayEye.LEFT);

// Get kc, camera_model of left eye
distortionParams = NRFrameExtension.GetGrayCameraDistortion(
                   NativeGrayEye.LEFT);







Extrinsic parameters

Extrinsic parameters corresponds to rotation and translation vectors which translate a coordinates of a 3D point to a coordinate system.

Pose leyePose = NRFrameExtension.GrayEyePoseFromHead.LEyePose;

// The following utility (or ConversionUtility) converts a pose to a matrix
extrinsicMat = PoseToTransformMatrix(leyePose);

public class Utility
{
    public static NativeMat4f PoseToTransformMatrix(Pose pose)
    {
        NativeMat4f mat4f = NativeMat4f.identity;

        Vector3 p = pose.position;
        Quaternion q = pose.rotation;
        q.z = -q.z;
        q.w = -q.w;

        float qxx = q.x * q.x;
        float qyy = q.y * q.y;
        float qzz = q.z * q.z;
        float qxz = q.x * q.z;
        float qxy = q.x * q.y;
        float qyz = q.y * q.z;
        float qwx = q.w * q.x;
        float qwy = q.w * q.y;
        float qwz = q.w * q.z;

        mat4f[0, 0] = 1f - 2f * (qyy + qzz);
        mat4f[0, 1] = 2f * (qxy + qwz);
        mat4f[0, 2] = 2f * (qxz - qwy);

        mat4f[1, 0] = 2f * (qxy - qwz);
        mat4f[1, 1] = 1f - 2f * (qxx + qzz);
        mat4f[1, 2] = 2f * (qyz + qwx);

        mat4f[2, 0] = 2f * (qxz + qwy);
        mat4f[2, 1] = 2f * (qyz - qwx);
        mat4f[2, 2] = 1f - 2f * (qxx + qyy);

        mat4f[3, 0] = p.x;
        mat4f[3, 1] = p.y;
        mat4f[3, 2] = -p.z;

        mat4f[0, 3] = .0f;
        mat4f[1, 3] = .0f;
        mat4f[2, 3] = .0f;
        mat4f[3, 3] = 1.0f;

        return mat4f;
    }
}






IMU RawData

 var m_NRIMUProvider = new NRIMUDataProvider(OnUpdate);
 m_NRIMUProvider.Start();

 private void OnUpdate(IMUDataFrame frame)
 {
      // frame is the imu rawdata
 }


 // or you can get it in "Update"
void Update()
{
    if (m_NRIMUProvider == null)
    {
        return;
    }

    var frame = m_NRIMUProvider.GetCurrentFrame();
    // frame is the imu rawdata

}







Image Tracking

To use image tracking feature, set Image Tracking Mode as ENABLE in NRKernalSessionConfig config file.

using NRKernal;
using System;
using System.Collections;
using System.Collections.Generic;
using UnityEngine;
using UnityEngine.Events;

public class MarkerObserver : MonoBehaviour
{
    public Action<NRTrackableImage> onTrackingBegin;
    public Action<NRTrackableImage> onTracking;
    public Action<NRTrackableImage> onTrackingEnd;

    /// <summary>
    /// Hold all tracking images database indexes.
    /// </summary>
    private HashSet<int> m_TrackingImageIndexes = new HashSet<int>();

    private List<NRTrackableImage> m_TrackableImages = new List<NRTrackableImage>();

    void Update()
    {
        NRFrame.GetTrackables<NRTrackableImage>(m_TrackableImages, NRTrackableQueryFilter.All);
        foreach (var trackableImage in m_TrackableImages)
        {
            int databaseIndex = trackableImage.GetDataBaseIndex();

            if (trackableImage.GetTrackingState() == TrackingState.Tracking)
            {
                if (!m_TrackingImageIndexes.Contains(databaseIndex))
                {
                    m_TrackingImageIndexes.Add(databaseIndex);
                    onTrackingBegin?.Invoke(trackableImage);
                }
                else
                {
                    onTracking?.Invoke(trackableImage);
                }
            }
            else
            {
                if (m_TrackingImageIndexes.Contains(databaseIndex))
                {
                    m_TrackingImageIndexes.Remove(databaseIndex);
                    onTrackingEnd?.Invoke(trackableImage);
                }
            }
        }
    }
}







Native API




NativeHMD

bool GetCameraIntrinsicMatrix(int eye, ref NativeMat3f CameraIntrinsicMatix)









          

      

      

    

  

  
    

    First Person View
    

    
 
  

    
      
          
            
  
First Person View


Operating environment


	【Hardware】 PC/Android mobile phone + Adapted mobile phone or Compute Unit + Nreal Light


	【Version】 SDK:v1.5.6_beta and above






Steps


	Import NRSDKForUnityAndroid_Beta_v1.5.12.unitypackage


	Drag “FPSStreamingCast” prefab into your scene

[image: ../../../_images/6f27538eb6ac00d94eba4b1b23277bf7bd08430c.png]


	Build and install


	Open the server application
Windows platform :
“StreamingReceiver/StreamingReceiver.exe” in pc

[image: ../../../_images/e057492b25578d837639b973b8db097418961818.png]
Android platform :
Install the “StreamingReceiver.apk” to a android phone



	Select FirstPersonView Menu.

[image: ../../../_images/d7c5055d0f4fed701c37502b04f521621775301f.png]


	Start the app build with NRSDK, When the ray is pointed to the top of the field of vision, the menu bar will appear. After you click the “stream” button, it will automatically search the server program in the local LAN, connect it, and then transmit the video stream.

[image: ../../../_images/308253ce072a78960dd6ac71b85bbada3159161b.png]






Note


	Ensure Server and client are in the same local area network.


	Turn off the firewall in server(if windows platform)
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    Mapping
    

    
 
  

    
      
          
            
  
Mapping


Operating environment


	【Hardware】 PC/Android mobile phone + Adapted mobile phone or Compute Unit + Nreal Light


	【Version】 SDK:v1.5.7_beta and above






Import NRSDKBeta Package

Import latest SDKBeta version package.



Open the Sample Scene

In the Unity Project window, you can find the CameraCaptureDemo sample in: Assets > NRSDKBeta >Demos > MappingExample.



Use the NRWorldAnchorStore step by step


See CameraCaptureController.cs , located in Assets > NRSDKBeta > Demos > Mapping > Scripts > LocalMapExample for an example on how to use the video capture.





	To begin with creating an instance of NRWorldAnchorStore, SDK will load the offline map file from the path (/sdcard/Android/data/{your app’s name}/files/NrealMaps) automatically and return the value of instance asynchronously.


// Create NRWorldAnchorStore object.
public void Load()
{
    NRWorldAnchorStore.GetAsync(GetAnchorStoreCallBack);
}

private void GetAnchorStoreCallBack(NRWorldAnchorStore store)
{
    myAnchorStore = store;
}










	Use the GetAllIds() method of NRWorldAnchorStore to get information about all anchors (NRWorldAnchor objects, hereinafter referred to as anchors) under the current map. This anchor is the anchor added and saved during the last run of the program. Use the Load (key, behaviour) interface according to the key value to Load the corresponding object, instantiation of objects will automatically be placed as a child of the anchor which will update its pose information every frame.


var keys = myAnchorStore.GetAllIds();
if (keys != null)
{
    foreach (var key in myAnchorStore.GetAllIds())
    {
        // Instantiate the gameobject by key.
        GameObject prefab;
        if (m_AnchorPrefabDict.TryGetValue(key, out prefab))
        {
            var go = Instantiate(prefab);
            myAnchorStore.Load(key, go);
            m_LoadedAnchorDict[key] = go;
        }
    }
}










	To delete all anchors, please utilize the method myAnchorStore.Clear(). Once executing this function, the project can’t load any anchor date.


myAnchorStore.Clear();










	To add more anchors, please utilize Load() interface and income the value of the key and an instance of gameobject. By utilizing this interface, NRSDK will create an anchor according to the position of the gameobject and put the instance of the gameobject under the node of this anchor. If the key-value belongs to one of the previous anchors, the previous one and its child objects will be deleted.


var go = Instantiate(target.gameObject);
go.transform.position = target.position;
go.transform.rotation = target.rotation;
go.SetActive(true);

string key = go.GetComponent<AnchorItem>().key;
bool result = m_NRWorldAnchorStore.Load(key, go);










	To save all anchors in the storage, please utilize the method myAnchorStore.Save (). Once it saves the anchors, the program will load the objects according to keys in the next runs


myAnchorStore.Save();














Run your build application


	Name the offline map as “nreal_map.dat” and push it under the folder /sdcard/Android/data/{your app’s name}/files/NrealMaps. Please create the folder if you don’t have one.


	Run the app and click the load button to load the map.


	Click “OpenAnchorPanel” button to open a panel. Put the anchor model in the same position as the anchor in the map and click the “Save”button and exit the app.


	For the following times: If you are in the same environment at where the map is captured before, the NRSDK will detect the environment and display the virtual objects after executing “load”
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